Post-Incident Update: On October 20, Firebolt services in the US-EAST-1 region experienced disruptions related to a broader AWS outage impacting multiple services, including DynamoDB. During this time, some customers in the us-east-1 region may have encountered increased latency, query suspensions, or ingestion job failures.
The underlying AWS issue has since been fully resolved, and all Firebolt services have returned to normal operation. No other regions were affected.
We continue to monitor system performance closely to ensure stability.
Posted Oct 21, 2025 - 11:14 UTC
Monitoring
Engine and database operations in us-east-1 are generally available but may experience increased error rates as AWS continues to stabilize services. We are monitoring and will update this page once all services have been confirmed to resume normal performance levels.
Posted Oct 20, 2025 - 21:42 UTC
Identified
AWS is currently throttling requests for new EC2 instance launches to aid recovery and actively working on mitigations. This may impact the start up times of your engines.
Posted Oct 20, 2025 - 15:50 UTC
Investigating
Some Firebolt services may experience latency or disruptions due to an ongoing AWS outage in the US-EAST-1 region.
The issue is impacting multiple AWS services, which may affect engine operations and data access in this region.
Our team is actively monitoring the situation and working to minimize customer impact. We'll share updates as more information becomes available from AWS.
Posted Oct 20, 2025 - 07:11 UTC
This incident affected: Firebolt Components (Engines, Databases) and AWS (AWS ec2-us-east-1).